Click on the "Get updates" button to stay up to date on TV and Radio signal notifications.

Resolved
WMVE-FM Off-Air

Started
July 17, 2021 at 10:46 PM
Status
Resolved after about 2 hours

Impact

Major outage
Affected
Radio
Chase City 90.1
  • Resolved
    July 18, 2021 at 12:36 AM

    Power has been restored WMVE back on-air

  • Monitoring
    July 17, 2021 at 10:46 PM

    Power outage in the Chase City, VA area