Click on the "Get updates" button to stay up to date on TV and Radio signal notifications.

Resolved
WCVE-FM Maintenance

Started
March 20, 2021 at 1:50 PM
Status
Resolved after 3 days

Impact

Partial outage
Affected
Radio
VPM News 88.9
  • Resolved
    March 23, 2021 at 6:03 PM

    We just resolved the issue!

  • Investigating
    March 20, 2021 at 1:50 PM

    WCVE FM will be performing maintenance on Saturday 3/20 for several hours beginning at 10:00 AM. This may include assorted periods of brief interruptions or noisy signal.