Click on the "Get updates" button to stay up to date on TV and Radio signal notifications.

Resolved
90.1 Chase City at Reduced Power

Started
February 19, 2021 at 6:54 PM
Status
Resolved after 3 days

Impact

Partial outage
Affected
Radio
Chase City 90.1
  • Resolved
    February 22, 2021 at 2:23 PM

    We just resolved the issue!

  • Monitoring
    February 19, 2021 at 6:54 PM

    Due to on-ongoing wintry ice conditions, the broadcast signal for 90.1 FM - which serves the Chase City / Southside Virginia area - is operating at reduced power.